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Preface 

 
 
 
 

The purpose of this manual is to serve as a self-instructional guide to those who want to convert 
Winisis database into greenstone application (as is conversion) with Greenstone digital library 
software 2.72 independently. 
 
The manual can be used as a training handout for exposure training that long for one or two days. 
The basic approach of the manual is to include the essential and easy-to-learn things and to exclude 
everything else that cannot be learned by new users.   
 
In exposure training, please desist from showering a lot of information of complex nature to the new 
participants who cannot digest all of them. That many dispel some of them from greenstone. 
 
Practice reminds that learning happens in the form of layers one over the other. When the first layer is 
not stable, you cannot build up the subsequent layers. This manual deals with the first layer of 
knowledge on implementation of greenstone. Advance features are not dealt with in this manual. 

 
We express our gratitude to Dr. John Rose for the enthusiasm he has shown in clarifying our doubts 
and helping us learn newer changes, without which the document would have more infirmities.  
 
 
 
 
 
Mulakunnathukavu        K. Rajasekharan  
25-05 -2007         K.M Nafala 
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Abstract 
 
The purpose of this guide is to narrate the steps to convert a Winisis database to a greenstone application, in an 

easy to understand manner. The details of software required, the address of download sites and the manner of 

creating the greenstone application are explained in the guide with screenshots. The guide would be useful to 

those who are experienced in Winisis and want to convert the database to Greenstone. The greenstone 

application thus creates can be uploaded in a website or published in a CD-ROM. 

 

1. Objective of this Guide 

 
The objective of this guide is to convert a Winisis database into a Greenstone Digital 

Library application.  The converted greenstone collection  can be put on the World 

Wide Web or it can be published on a CD-ROM. 

 

1.1 Sample Winisis Database Chosen for Conversion 

 
We may choose the Winisis database cds that appears along with the software, for 

this experimentation. You can choose any other database for conversion. A sample 

Winisis database may contain fields such as Title, Author, and Keywords etc. The 

sample database cds.mst will appear as follows: - 

 

 

 

 

 

 

                                                 
*   Librarian, Kerala Institute of Local Administration, Mulagunnathu Kavu – 680 581 
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Figure 1 Winisis Archive   

 
 

2. Software Installation 
 

2.1 Software Download  

 
The GSDL 2.72 software can be downloaded from 

http://prdownloads.sourceforge.net/greenstone/gsdl-2.72-win32.exe 

Java2 Runtime Environment can be downloaded from 

http://greenstonesupport.iimk.ac.in/software/jre-1_5_0_05-windows-i586-p.exe 

 
ImageMagick can be had from http://greenstonesupport.iimk.ac.in/software/ImageMagick-
6.2.3-2-Q16-windows-dll.exe  
 
 
Ghostscript can be obtained from http://downloads.sourceforge.net/ghostscript/gs854w32-

gpl.exe?modtime=1155148078&big_mirror=1 

 

Winisis 1.5 can be downloaded from www.unesco.org/isis/files/winisislicense .html 
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2.2 Installation of Software 

 
Install Java2 Runtime Environment in your computer as a pre-requisite for 

installing GSDL software. Then install the GSDL 2.72 (windows version) software in 

your computer. Choose the recommended Local Library mode for installation.  

 

You may install ImageMagick and Ghostscript softwares, required to build image 

collections and to do advanced conversion of PDF and Postscript documents, 

respectively.  Otherwise these two softwares are not required. 

 

3. Conversion of Winisis into Greenstone Application 

 
Open the Greenstone Librarian Interface (GLI) Start ⇒ Programs ⇒ Greenstone 

Digital Library Software v2.72 ⇒ Greenstone Librarian Interface. 

To create a new collection, choose New from File menu 

 
Figure 2 Starting a New Collection 

 
 

Give a title for the collection (say Winisis) and give a short description about the 

collection as shows in the following figure.  

 
  



Figure 3 Collection Name & Description 
 

 

Type the 
name of the 
collection 

Type the 
description here 

Click here to 
select New 
Collection 

 
 
 
 
Select New Collection under Base this collection on dialogue and click OK button. 
 

4. Gather the Database Files 

 
Now the Gather panel will become active. Locate .mst, .fdt & .xrf files from your 

Winisis database (normally at C:\Winisis\cds) and drag them into the Collection 

panel as in the following screen: - 

 

Figure 4 Gathering the Files 

 



5.  Designing the Collection 
 
Then design the collection by choosing the following features given under the 

Design menu. Collection design consists of many facets enlisted in the left pane.  

 
5.1 Create Search Indexes 

 
Choose the Search Indexes, shown on the left pane, for creating Search Indexes.  

Remove the default indexes and add new search indexes. 

 

5.2 Remove the Default Indexes 

 
Remove the default indexes for ex.Title, ex.PersonalAuthors and ex.Keywords by 

selecting the index description under Assigned Indexes and then by clicking on the 

Remove Index button.  

 

Figure 5 Removing index 

 

 

Select the index 

Click here to 
remove index 

 
 
 
 
 

Click here to select 
search index 



5.3 Adding New Indexes 

 
Click on the New Index button. Select the ex.Title, ex.PersonalAuthors and 

ex.Keywords,  by tick marking on the check box one by one,   and add them  one by 

one by clicking on the Add Index button. That means select ex.Title first and add it, 

then select ex.PersonalAuthors and add it, then select ex.Keywords and add it and so 

on. 

 
Figure 6 Adding Index for ex.Title   
 

 
 
 

add index add New index 
Click here to Put a tick mark to select 

search index 
Click here to  

 
 
Select and add the Search Index for PersonalAuthors by choosing the metadata 

(ex.PersonalAuthors) as follows:- 

 



Figure 7 Adding Search Index for ex.PersonalAuthors 
 

 
 

Put a tick mark to 
select search index 

 

 

Select and add the Search Index for Keywords by choosing the metadata (ex.Keywords) 

as follows:- 

 
Figure 8 Adding Search Index for ex.Keywords 

 

Put a tick mark to 
select search index 

 

 

 

The three indexes will be added one by one as in the following figure. 

 



Figure 9 Indexes Selected for the Collection 

 

 
 
You can move any index up or down to set its order of appearance by selecting the 

index and clicking on the buttons on the right side.  Likewise you can set any index 

as default index by selecting the index and clicking on the Set Default Index button.  

 

5.4 Browsing Classifiers 

 
If you want to browse on a metadata element, you must set up a Browsing Classifier, 

independently of creating a search index on this metadata element. The metadata 

used for the database are Title, PersonalAuthors, Keywords and we need to create 

browsing classifiers for them. The default Browsing Classifiers are as follows:- 

 



Figure 10 Default Browsing Classifiers 

 

 

Click here to Add 
classifier 

Click here to 
Remove classifier 

 
 
 
 
 

Select Browsing Classifier by clicking on it and then click on the Remove Classifier 

button for removing the default classifiers  one by one.  The resultant screen would 

be as follows:- 

 

Figure 11 Adding Classifier 

 
 
 
 

 

Click here to Add 
Classifier 



5.5 Adding Browsing Classifiers 

 
Now, choose Select classifier to add pull down list and select A-Z List or A-Z 

Compact List 1. 

 

Then click on Add Classifier and add the Browsing Classifiers2 for Title, 

PersonalAuthors and Keywords by one by one.  

 

When you click Add Classifier button in the above screen, you will get the window 

for choosing the Browsing Classifier like Title, Personal author, Keywords etc. 

 
Select the browsing classifier for Title by choosing the metadata option (ex.Title)  as 

follows:- 

 
Figure 12 Adding Classifier CL1 for Title - ex.Title 
 

 

Click here to 
select metadata

(ex.Title) 

 

Click OK button to add Title classifier. 

 

                                                 
1 Use of AZCompactList Classifier brings bookshelf icons under the browsing classifier. It groups together the 
documents that appear multiple times with same metadata and does not differ with AZList in any other manner.  
2 If you want to give a button name other than the button names like Titles, Creators etc, check the buttonname 
box in the "Configuring Arguments" window, type the desired button name and click Ok. 



Then select the browsing classifier for PersonalAuthors by choosing the metadata 

option (ex.PersonalAuthor) as follows :- 

 
 

Figure 13 Adding Classifier CL2 for Author  - ex.PersonalAuthors 

 

 

Click here to 
select metadata 

(exp.PesonalAuth
ors) 

 
Click OK button to add PersonalAuthors classifier. 

 
Figure 14 Adding Classifier CL3 for ex.Keywords 
 

 

Click here to 
select metadata 
(exp.Keywords) 

 
Click OK button to add Keywords classifier. 

 



The resultant screen, that shows the three added Browsing Classifiers, will appear as 

follows:- 

 

Fig 15 Browsing Classifiers assigned for this sample Collection 

 

 
 

6.  Format 
 
Many aspects of the page-display of the resultant digital library are governed by the 

features provided under the Format menu.  We do not explain Format Features here, 

as it is a bit complex for beginners. 

 

7.  General  
 
Choose the Format Tab and select General to provide the general information about 

the collection.  

 

7.1 Put a picture as a collection icon 

 
Choose a small picture of around 100*100 pixels that needs to appear as an icon of 

the collection in the homepage, by clicking on the Browse button on middle right 

and selecting the picture. On choosing the picture, the full path of the picture will 

appear in the address box lying against the Browse button.  



Figure 16 Designing the Collection – General Information 

 

 

 
 

Click here to  
select picture 
as 'homepage' 

icon 
 
 Click here to select
 
8. Build the Collection 
 
 
Then go to the Create panel. Click on the Build Collection button and the progress- 

window will show the progress in building the collection. 

 

Fig  17 Building a Collection 

  

 

Click here to build 
collection 

 



Click OK button when the building process is completed. 
 
Click on the Preview Collection button to show the collection. 
 
 
Figure 18 Home Page of the Demo Collection 
 

 
 
 
Figure 19 Browse the Collection by Title Classifier 
 

 
 
 
 
 
 



Figure 20 Browse the Collection by Personal Authors Classifier 
 

 
 
 
Figure 21 Browse the Collection by Keywords Classifier 
 

 



Figure 22   Display of One Record in the Database 
 

 
 
 

9. Converting the Collection in to a CD-ROM Library 

 
You can write the collection/collections to a CD-ROM, if you want to convert the 

Greenstone collection into an installable CD-ROM for distribution among wider 

audience. 

Click on File ⇒ Write CD/DVD image...... 
 
 
Figure 23 Starting the Writing Process 

 



A pop-up window will appear as follows:- 
 
 
Figure 24 Giving a Collection Name for CD-ROM 

 

 

Type CD-ROM 
name here 

Put a tick mark to select 
the collection to export 

 
 

Click here to Write 
CD/DVD Image  

 

Provide a name for your CD-ROM (winisis collection), put a tick mark the check box 

pertaining to the collection and click Write CD/DVD image button. 

 
Figure 25 Export completed 

 

 

Read this and do what is said

 



Click Close button   
 

Then write the contents of the folder (C:\ProgramFiles\Greenstone\ 

tmp\exported_Winisis) into a blank CD-ROM for creating self-installing Windows 

CD-ROM library. 
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