A look at metadata processing beyond Libraries

Pasqui, Valdo A look at metadata processing beyond Libraries. JLIS.it, 2022, vol. 13, n. 3, pp. 29-48. [Journal article (Paginated)]

[thumbnail of jlis_492_1.pdf]
Preview
Text
jlis_492_1.pdf - Published version
Available under License Creative Commons Attribution.

Download (1MB) | Preview

English abstract

Since many years libraries, archives and museums, the institutions entrusted with the dissemination and conservation of cultural heritage, contributed to metada standards definition, meta-dating methodologies and metadata representation in different syntaxes, by partecipating to national projects and international initiatives.Management systems and catalogs used in these contexts borrow from information and telecommunication technology tools, metodoligies and techniques to generate, organize, share and use various types of metadata. But the Information and Communication Technology (ICT) area is not only a supplier of technological tools and solutions as it also constitutes a rich basin in which metadata plays a fundamental role in designing architectures, modeling information systems and implementing services.Through an overview that includes national and European initiatives, especially in the digital transformation process of the public sector, this paper aims to offer a look to metadata beyond the traditional boundary of libraries and other cultural institutions and to underline some relevant aspects such as standardization, sharing, reuse and metadata quality assessment.This framework highlights the need to carry on with the path of cooperation between different functional domains and organizational contexts in order to consolidate and extend the (re)use of metadata schemes, ontologies and controlled vocabularies both in the redesign of digitized processes and in the implementation of services supporting them.  By undertaking  since design early stages a multidisciplinary approach based on metadata standards can ensure greater flexibility and higher interoperability. This vision requires the enhancement of intersectorial skills that meld metadata methodologies and syntaxes representation basic knowledge  with the ability to model functional domains using metadata schemes and ontologies.

Italian abstract

I metadatati, le metodologie di metadatazione e le sintassi per rappresentare i metadati sono ambiti nei quali le biblioteche, gli archivi e i musei, istituzioni alle quali è affidata la diffusione e la conservazione del patrimonio culturale, da molti anni hanno contribuito alla definizione di standard e allo sviluppo di metodologie grazie anche a progetti nazionali e iniziative internazionali. I sistemi gestionali e i cataloghi di cui si avvalgono questi contesti mutuano dalle tecnologie informatiche e delle telecomunicazioni tecniche e strumenti che consentono di generare, organizzare, condividere e usare le varie tipologie di metadati. Ma l’area Information and Communication Technology (ICT) non è solo un fornitore di strumenti e soluzioni tecnologiche poiché costituisce anche un ricco bacino nel quale i metadati svolgono un ruolo fondamentale per il disegno delle architetture, per la modellazione dei sistemi informativi e per l’implementazione dei servizi. Attraverso una panoramica che comprende iniziative nazionali e europee, soprattutto nell’ambito della trasformazione digitale del settore pubblico, questo contributo intende offrire uno sguardo oltre al confine dei metadati del mondo bibliotecario e delle altre istituzioni culturali e mettere in evidenza alcuni aspetti rilevanti come la standardizzazione, la condivisione, il riuso e la qualità dei metadati. Dal quadro esaminato emerge la necessità di proseguire nel cammino intrapreso per promuovere la cooperazione tra i diversi domini funzionali e i vari contesti organizzativi al fine di consolidare e ampliare l’uso degli schemi di metadati, delle ontologie e dei vocabolari controllati nella progettazione dei processi digitalizzati e dei servizi che li supportano. Un approccio multidisciplinare che si fonda sull’uso di schemi di metadati può assicurare fin dalle prime fasi della progettazione maggiore flessibilità e una più elevata interoperabilità. Questa visione richiede lo sviluppo di competenze intersettoriali che uniscano alla conoscenza delle metodologie di metadatazione e delle sintassi di rappresentazione dei metadati anche la capacità di modellare i domini funzionali avvalendosi degli schemi di metadati e delle ontologie.

Item type: Journal article (Paginated)
Keywords: Metadata; Open Data; Web Services; API; Ontologies; Controlled vocabularies; Interoperability; Ontologie; Vocabolari controllati; Interoperabilità
Date deposited: 15 Sep 2026 05:10
Last modified: 20 Sep 2026 22:24
URI: http://hdl.handle.net/10760/48905

References

AgID (Agenzia per l’Italia Digitale).2022. Attuazione Misure PNRR. https://www.agid.gov.it/it/agenzia/attuazione-misure-pnrr

ArCo. 2017. MiC (Ministero della Cultura). Progetto Arco – Architettura della conoscenza. Ultimo accesso 5 Maggio 2022. https://dati.beniculturali.it/progetto-arco-architettura-della-conoscenza/

Bagley, Philip.1968. Extension of programming language concepts. Philadelphia: University City Science Center. Archived (PDF) from the original on November 30, 2012. https://web.archive.org/web/20121130091053/http://www.dtic.mil/dtic/tr/fulltext/u2/680815.pdf

CAD. 2021 Decreto Legislativo 7 marzo 2005, n. 82 - Codice dell'amministrazione digitale. Successive modifiche (Ultimo aggiornamento all'atto pubblicato il 31/12/2021). https://www.normattiva.it/uri-res/N2Ls?urn:nir:stato:decreto.legislativo:2005-03-07;82!vig=

DCAT. 2020. Data Catalog Vocabulary (DCAT) - Version 2 - W3C Recommendation 04 February 2020. https://www.w3.org/TR/vocab-dcat-2/

DCAT-AP. 2022. Data Catalog Vocabulary (DCAT) Application Profile for data portals. https://joinup.ec.europa.eu/collection/semantic-interoperability-community-semic/solution/dcat-application-profile-data-portals-europe/release/210

DCAT-AP_IT. 2022. DCAT-AP_IT v1.1 – Profilo italiano di DCAT-AP. AgID (Agenzia per l’Italia Digitale). https://dati.gov.it/content/dcat-ap-it-v10-profilo-italiano-dcat-ap-0

Directive (EU) 2019/1024. 2019 Directive (EU) 2019/1024 of the European Parliament and of the Council of 20 June 2019 on opendata and the re-use of public sector information. Ultimo accesso 5 Maggio 2022. https://eur-lex.europa.eu/legal-content/EN/TXT/?uri=celex%3A32019L1024

eduPerson. 2016. eduPerson Object Class Specification (201602). Internet2. February 2016. http://software.internet2.edu/eduperson/internet2-mace-dir-eduperson-201602.html

e-GOV. n.d. Releases for e-Government Core Vocabularies solution. Ultimo accesso 5 Maggio 2022. https://joinup.ec.europa.eu/collection/semantic-interoperability-community-semic/solution/e-government-core-vocabularies

EUDati. 2020. Comunicazione della Commissione al Parlamento Europeo, al Consiglio, al Comitato Economico e Sociale Europeo e al Comitato delle Regioni. Una strategia europea per i dati. Document 52020DC0066. 2020. https://eurlex.europa.eu/legal-content/IT/TXT/?qid=1593073685620&uri=CELEX%3A52020DC0066

FAIR. n.d. FAIR (Findability, Accessibiliy, Interoperability, Interoperabilità and Reusability) Principles. Ultimo accesso 5 Maggio 2022. https://www.go-fair.org/fair-principles/

Fielding, Roy T. 2000. Architectural Styles and the Design of Network-based Software Architectures University of California, Irvine, 2000. https://www.ics.uci.edu/~fielding/pubs/dissertation/top.htm

GÉANT.n.d. Ultimo accesso 5 Maggio 2022. http://www.geant.org/

IBM. 2014. 100 ans d’IBM en France. http://centenaireibmfrance.blogspot.com/2014/04/1955-terme-ordinateur-invente-par-jacques-perret.html

INSPIRE. 2007. Directive 2007/2/EC of March 2007 establishing an Infrastructure for Spatial Information in the European Community (INSPIRE). https://eur-lex.europa.eu/legal-content/EN/ALL/?uri=CELEX%3A32007L0002

INSPIRE_REG_IT. n.d. INSPIRE Italia Registry. Ultimo accesso 5 Maggio 2022. https://registry.geodati.gov.it/registry

INSPIRE_TG. 2022 Technical Guidance for the implementation of INSPIRE dataset and service metadata based on ISO/TS 19139:2007. https://github.com/INSPIRE-MIF/technical-guidelines/blob/2022.1/metadata/metadata-iso19139/metadata-iso19139.adoc#conformance-classes-for-spatial-data-services

Joinup-CV. 2022. e-Government Core-Vocabularies. https://joinup.ec.europa.eu/collection/semantic-interoperability-community-semic/solution/e-government-core-vocabularies/release/200-0

LGNVPIP. 2020. Linee Guida Nazionali per la Valorizzazione del Patrimonio Informativo Pubblico 13 Febbraio 2020. https://docs.italia.it/media/pdf/lg-patrimonio-pubblico/bozza/lg-patrimonio-pubblico.pdf

Media Types. 2022. Media Types. Internet Assigned Numbers Authority (IANA) 2022. https://www.iana.org/assignments/media-types/media-types.xhtml

NSO n.d. Nodo di smistamento degli ordini di acquisto delle amministrazioni pubbliche (NSO). MEF (Ministero dell’Economia e Finanze) Ragioneria Generale dello Stato. https://www.rgs.mef.gov.it/VERSIONE-I/e_government/amministrazioni_pubbliche/acquisti_pubblici_in_rete_apir/nodo_di_smistamento_degli_ordini_di_acquisto_delle_amministrazioni_pubbliche_nso/

OAIS. 2012. Reference Model For An Open Archival Information System (OAIS). Consultative Committee for Space Data Systems. June 2012. Standard ISO 14721:2012. https://public.ccsds.org/pubs/650x0m2.pdf

OASIS. n.d. Organization for the Advancement of Structured Information Standards. Ultimo accesso 5 Maggio 2022. https://www.oasis-open.org/

OAS. n.d.OpenAPI Specification Version 3.0.3 Ultimo accesso 5 Maggio 2022. https://swagger.io/specification/

OpenBadges 2.0. 2021. Open Badges v2.0 IMS Final Release. https://www.imsglobal.org/sites/default/files/Badges/OBv2p0Final/index.html

OCDS. n.d. The Open Contracting Data Standard. Ultimo accesso 5 Maggio 2022. https://www.open-contracting.org/data-standard/

OCDS_Port. n.d. Portale dei dati aperti dell’Autorità Nazionale Anticorruzione. Ultimo accesso 5 Maggio 2022. https://dati.anticorruzione.it/opendata/ocds

PDFA. 2005. ISO 19005-1:2005 Document Management - Electronic document file format for long term preservation - Part 1: Use of PDF 1.4 (PDF/A-1). https://www.iso.org/standard/38920.html

PTIPA. 2021. Piano triennale per l’informatica nella PA – Aggiornamento 2021 – 2023 (versione notificata alla Commissione Europea) - Agenzia per l’Italia Digitale e Dipartimento per la Trasformazione Digitale. Roma, ottobre 2021. https://www.agid.gov.it/sites/default/files/repository_files/piano_triennale_per_linformatica_nella_pubblica_amministrazione_2021-2023.pdf

RDF. 2014. RDF 1.1 Concepts and Abstract Syntax. W3C Recommendation 25 February 2014. https://www.w3.org/TR/rdf11-concepts/

REFEDS. n.d. REFEDS (the Research and Education FEDerations group). Ultimo accesso 5 Maggio 2022. https://refeds.org/

RFC 2252. 1997. Lightweight Directory Access Protocol (v3): Attribute Syntax Definitions. RFC 2252 December 1997. https://datatracker.ietf.org/doc/html/rfc2252

RFC 2256. 1997. A Summary of the X.500(96) User Schema for use with LDAPv3. RFC 2256 December 1997. https://www.ietf.org/rfc/rfc2256.txt

RFC 2798. 2000. Definition of the inetOrgPerson LDAP Object Class. RFC 2798 April 2000. https://www.ietf.org/rfc/rfc2798.txt

RFC 4519. 2006. Lightweight Directory Access Protocol (LDAP): Schema for User Applications. RFC 4519 June 2006. https://www.ietf.org/rfc/rfc4519.txt

SAML. n.d. Security Assertion Markup Language (SAML) v2.0. Ultimo accesso 5 Maggio 2022. https://www.oasis-open.org/standards/

SHACH. 2022. SCHAC - SCHema for Academia. https://wiki.refeds.org/display/STAN/SCHAC

SDG. n.d. The single digital gateway and Your Europe. Ultimo accesso 5 Maggio 2022 https://ec.europa.eu/growth/single-market/single-digital-gateway_it

SDI n.d. Fatturazione elettronica verso la Pubblica amministrazione. Sistema di Interscambio. Ultimo accesso 5 Maggio 2022. https://www.fatturapa.gov.it/it/sistemainterscambio/cose-il-sdi/

SPID_AT. n.d. SPID Tabella attributi. Ultimo accesso 5 Maggio 2022. https://www.agid.gov.it/sites/default/files/repository_files/regole_tecniche/tabella_attributi_idp_v1_0.pdf

SPID_REG. n.d. SPID Registry. Ultimo accesso 5 Maggio 2022. https://registry.spid.gov.it/

SPID_RT. n.d. SPID Metadata. https://github.com/italia/spid-regole-tecniche/blob/96287a228c8dbf817a4b0b1c41e234d4e231a830/metadata.rst

TALLIN. 2017. Tallinn Declaration on eGovernment. https://ec.europa.eu/newsroom/document.cfm?doc_id=47559

Berners-Lee, Tim. 2006. Linked Data—Design Issues. http://www.w3.org/DesignIssues/LinkedData.html

Vallejo, Irene. 2021. Payprus. L’infinito in un giunco. La grande avventura del libro nel mondo antico. Firenze: Giunti Editore/Bompiani.

Wiederhold, Gio. 1997. Database Design, Tokio: McGraw-Hill computer science series.

W3CWS. 2004. Web Services Glossary W3C Working Group Note. 11 February 2004. https://www.w3.org/TR/2004/NOTE-ws-gloss-20040211/#webservice

WSDL 2.0. 2007 Web Services Description Language (WSDL) Version 2.0 Part 1: Core Language. http://www.w3.org/TR/wsdl20

XSD. 2012. W3C XML Schema Definition Language (XSD) 1.1 Part 1: Structures W3C Recommendation. 5 April 2012 https://www.w3.org/TR/xmlschema11-1/ e W3C XML Schema Definition Language (XSD) 1.1 Part 2: Datatypes W3C Recommendation 5 April 2012 https://www.w3.org/TR/xmlschema11-2/


Downloads

Downloads per month over past year

Actions (login required)

View Item View Item